Experience Portal: EPM failed to retrieve license from SMGR after power outage


Doc ID    SOLN324339
Version:    5.0
Status:    Published
Published date:    19 Oct 2021
Created Date:    16 Apr 2018
Author:   
yongweiwang
 

Details

AEP was getting no License after Power outage, redployed the License on SMGR to recover outage.
The current license mode: EPM license link set to SMGR WebLM license server directly. SMGR is enterprise license

AAEP can not get the license form SMGR lincense server

Problem Clarification

 

#AAEP frees the license to weblm server.

<110>Mar 22 13:52:11 LoginId: NHI, ClientHost: 10.51.98.18, Action: Free licenses for feature belonging to product Voice_Portal acquired by VoicePortal:PNAEP01:20170407170939807, Result: SUCCESS, ObjectType: Licensed Feature, ObjectName: TelephonyPorts, [AttributeName: Freed license Count, OldValue: N/A, NewValue: 30]

#AAEP acquires licesnes from weblm sever

<110>Mar 22 13:52:11 LoginId: NHI, ClientHost: 10.51.98.18, Action: License acquisition for feature belonging to product Voice_Portal by acquirer VoicePortal:PNAEP01:20170407170939807, Result: SUCCESS, ObjectType: Licensed Feature, ObjectName: TelephonyPorts, [AttributeName: Acquired license Count, OldValue: N/A, NewValue: 30]

#This line means that AAEP tried to acquire 5000 licenses, but weblm server just give 30 licenses to it, and denied 4970.

<110>Mar 22 13:52:11 LoginId: NHI, ClientHost: 10.51.98.18, Action: License denial for feature belonging to product Voice_Portal by acquirer VoicePortal:PNAEP01:20170407170939807, Result: SUCCESS, ObjectType: Licensed Feature, ObjectName: TelephonyPorts, [AttributeName: Requested license Count, OldValue: N/A, NewValue: 5,000], [AttributeName: Acquired license Count, OldValue: N/A, NewValue: 30], [AttributeName: Denied license Count, OldValue: N/A, NewValue: 4,970]

 

#Here is another example procedure. This procedure happens every 5 minutes.

<110>Mar 22 13:57:26 LoginId: NHI, ClientHost: 10.51.98.18, Action: Free licenses for feature belonging to product Voice_Portal acquired by VoicePortal:PNAEP01:20170407170939807, Result: SUCCESS, ObjectType: Licensed Feature, ObjectName: TelephonyPorts, [AttributeName: Freed license Count, OldValue: N/A, NewValue: 30]

<110>Mar 22 13:57:26 LoginId: NHI, ClientHost: 10.51.98.18, Action: License acquisition for feature belonging to product Voice_Portal by acquirer VoicePortal:PNAEP01:20170407170939807, Result: SUCCESS, ObjectType: Licensed Feature, ObjectName: TelephonyPorts, [AttributeName: Acquired license Count, OldValue: N/A, NewValue: 30]

<110>Mar 22 13:57:26 LoginId: NHI, ClientHost: 10.51.98.18, Action: License denial for feature belonging to product Voice_Portal by acquirer VoicePortal:PNAEP01:20170407170939807, Result: SUCCESS, ObjectType: Licensed Feature, ObjectName: TelephonyPorts, [AttributeName: Requested license Count, OldValue: N/A, NewValue: 5,000], [AttributeName: Acquired license Count, OldValue: N/A, NewValue: 30], [AttributeName: Denied license Count, OldValue: N/A, NewValue: 4,970]

 

#14:09, AAEP tried to acquire licenses again without free license before that.

<110>Mar 22 14:09:34 LoginId: NHI, ClientHost: 10.51.98.18, Action: License denial for feature belonging to product Voice_Portal by acquirer VoicePortal:PNAEP01:20180322140934392, Result: SUCCESS, ObjectType: Licensed Feature, ObjectName: TelephonyPorts, [AttributeName: Requested license Count, OldValue: N/A, NewValue: 5,000], [AttributeName: Acquired license Count, OldValue: N/A, NewValue: 0], [AttributeName: Denied license Count, OldValue: N/A, NewValue: 5,000]

<110>Mar 22 14:14:35 LoginId: NHI, ClientHost: 10.51.98.18, Action: License denial for feature belonging to product Voice_Portal by acquirer VoicePortal:PNAEP01:20180322140934392, Result: SUCCESS, ObjectType: Licensed Feature, ObjectName: TelephonyPorts, [AttributeName: Requested license Count, OldValue: N/A, NewValue: 5,000], [AttributeName: Acquired license Count, OldValue: N/A, NewValue: 0], [AttributeName: Denied license Count, OldValue: N/A, NewValue: 5,000]

The issue happen when power outage happen on EPM server, after power outage restore, the EPM server failed to retrieve the license from SMGR License server.

Cause

#AAEP frees the license to weblm server.
<110>Mar 22 13:52:11 LoginId: NHI, ClientHost: 10.51.98.18, Action: Free licenses for feature belonging to product Voice_Portal acquired by VoicePortal:PNAEP01:20170407170939807, Result: SUCCESS, ObjectType: Licensed Feature, ObjectName: TelephonyPorts, [AttributeName: Freed license Count, OldValue: N/A, NewValue: 30]
#AAEP acquires licesnes from weblm sever
<110>Mar 22 13:52:11 LoginId: NHI, ClientHost: 10.51.98.18, Action: License acquisition for feature belonging to product Voice_Portal by acquirer VoicePortal:PNAEP01:20170407170939807, Result: SUCCESS, ObjectType: Licensed Feature, ObjectName: TelephonyPorts, [AttributeName: Acquired license Count, OldValue: N/A, NewValue: 30]
#This line means that AAEP tried to acquire 5000 licenses, but weblm server just give 30 licenses to it, and denied 4970.
<110>Mar 22 13:52:11 LoginId: NHI, ClientHost: 10.51.98.18, Action: License denial for feature belonging to product Voice_Portal by acquirer VoicePortal:PNAEP01:20170407170939807, Result: SUCCESS, ObjectType: Licensed Feature, ObjectName: TelephonyPorts, [AttributeName: Requested license Count, OldValue: N/A, NewValue: 5,000], [AttributeName: Acquired license Count, OldValue: N/A, NewValue: 30], [AttributeName: Denied license Count, OldValue: N/A, NewValue: 4,970]

#Here is another example procedure. This procedure happens every 5 minutes.
<110>Mar 22 13:57:26 LoginId: NHI, ClientHost: 10.51.98.18, Action: Free licenses for feature belonging to product Voice_Portal acquired by VoicePortal:PNAEP01:20170407170939807, Result: SUCCESS, ObjectType: Licensed Feature, ObjectName: TelephonyPorts, [AttributeName: Freed license Count, OldValue: N/A, NewValue: 30]
<110>Mar 22 13:57:26 LoginId: NHI, ClientHost: 10.51.98.18, Action: License acquisition for feature belonging to product Voice_Portal by acquirer VoicePortal:PNAEP01:20170407170939807, Result: SUCCESS, ObjectType: Licensed Feature, ObjectName: TelephonyPorts, [AttributeN

The issue is caused by power outage at the EPM server, it failed to free the license due to power outage. Once EPM is restored, but the WELM server was not free the license due to power outage , it cannot acquire the license again.

Solution

Recommend to set the Master and local mode. configure local license server in SMGR , and set the EPM server to use local license server. The license will be pushed from master to local periodically. If there is issue happen on EPM server due to power outage, the lEPM server reboot will reiniilize the status of license usage. if there is still any issue happen, Customer can re-allocate the license from master to local server.

Additional Relevant Phrases

Cannot share license on master weblm Alarma problemas de licencia de Experience portal, no se puede comunicar con el servidor de licencias

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