POM - When the client pause the campaign and after some time puts the campaign in resume, the agents do not receive the Nailer call and the agents are in the status of "Unailer / Detach Job".


Doc ID    SOLN324376
Version:    5.0
Status:    Published
Published date:    26 May 2022
Created Date:    17 Apr 2018
Author:   
facosta
 

Details

When the client pauses the campaign and after some time puts the campaign in resume, the agents do not receive the Nailer call and the agents are in the status of "Unailer / Detach Job".

Experience Portal 7.2.0.0.1201
MPP 7.2.0.0.1206
POM 03.01.00.00.03.019

 

Problem Clarification

When the client pauses the campaign and after while puts the campaign in resume, the agents do not receive the Nailer call and the agents are in the status of "Unailer / Detach Job". In the Agent Manager log I see this message.

03 Apr 2018 20:34:07,553 [AM-Default] FINEST - AM.allocateAgentToJobInstance:1546 - Agent ID:[119803] Agent Name:[119803] Agent Session ID:[1086] Agent Current State:[READY | UnNailed | Idle | JobDetached] Agent Prev State:[NOT_READY | UnNailed | Idle | JobDetached] Time Spent :[0] Msg:[Trying to attach the agent, Looking for the matching skill jobs]
03 Apr 2018 20:34:07,553 [AM-Default] FINEST - JobInstancePriorityList.createAllocateAgentJobList:129 - Not considering the job for allocation as it might be over/snoozing/max reached, job ID:725.

To return the Nailer calls to the agents I need to do a campaign stop / start.

Cause

We tried replicating the issue in our lab and we were able to replicate the issue in our lab with following scenario:

“This issue will happen when the campaign was paused and again resumed , and after resuming the campaign the first call was retry , that caused the issue of NULL pointer and the thread was blocked hence no further dialing and no nailup calls”

PIM_CmpMgr.log.1:05 Apr 2018 21:23:35,112 [SWT-734-initial-0] FINEST - CallPacer.processMakeCallResponse:249 - [c:279834] Make Another call.
PIM_CmpMgr.log.1:05 Apr 2018 21:23:35,112 [SWT-734-initial-0] ERROR - [c:279834] CallAction.readyToStartNewAttempt:426 -
PIM_CmpMgr.log.1:05 Apr 2018 21:23:35,112 [SWT-734-initial-0] FINEST - Action.execute:1265 - [c:279834] Sending request to queue next work
PIM_CmpMgr.log.1:05 Apr 2018 21:23:35,112 [SWT-734-initial-0] FINE - StateWorkerThread.run:271 - [c:279834] Error while processing a retry work element, contactId : 279834
PIM_CmpMgr.log.1:05 Apr 2018 21:23:35,112 [SWT-734-initial-0] ERROR - [c:279834] StateWorkerThread.run:273 -

Solution

Created the CFD OUTREACH-10519 for the issue.

Created this HF on top of latest POM 3.1 patch ( patch 4).- The attached file is in the ending of article.

- Stop or pause all running campaigns
- Stop POM and vpms services
- Unzip and copy files to POM server
- Take backup of the original “/opt/Avaya/avpom/POManager/lib/core/avaya-pim-core.jar” files.
- Copy HF avaya-pim-core.jar to “/opt/Avaya/avpom/POManager/lib/core/”
- Start vpms and POM services

Note - Install the latest POM patch( if already not installed ) before installing the fix.

Attachment File

CIEE_HF_1_13696597571.zip
777K • 2 minute(s) @ 56k, < 1 minute @ broadband



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