AACC 7.X AAAD fails with CCT Connection Failure, Agents cannot log in. Across multiple Domains


Doc ID    SOLN325672
Version:    2.0
Status:    Published
Published date:    01 Jun 2020
Created Date:    25 May 2018
Author:   
joselag
 

Details

Unable to launch AAAD Agent from computers on a separate domain. Receiving "CCT Connection Failure. Operation Failure Exception from CCT connect: Server Communication Failure"

Agents report the following error popup:

CCT Connection Failure: 
Operation Failure exception from CCT connect
ServerCommunicationsFailure.


This is a new installation for a department that is located on a separate domain. All users attempting to connect are receiving this error

Problem Clarification

.Per AACC Overview and Specification guide, Avaya Aura Contact Center domain considerations

Avaya Aura Contact Center supports only a Windows Server Active Directory domain. Avaya Aura  Contact Center supports a single forest implementation. Avaya Aura Contact Center supports agent integration within only those domains in the same forest as the Avaya Aura Contact Center domain. Avaya Aura Contact Center does not support agent integration across multiple forests, or in domains outside the Avaya Aura Contact Center forest.


All Avaya Aura  Contact Center servers must be in the same Windows Active Directory domain. All Avaya Aura Contact Center servers must be registered with the same Windows Active Directory Domain Controller. All Avaya Agent Desktop clients must be registered in this domain, or in domains with a two-way trust relationship with this Avaya Aura Contact Center server domain.


The Avaya Aura  Contact Center firewall policy defines the services, network ports, and Windows accounts necessary for contact center voice and multimedia functionality. Avaya Aura Contact Center does not provide or install a group policy. A group policy manages and configures software applications and user settings in a given environment. Avaya Aura Contact Center cannot be customized to accommodate individual corporate domain structures or group policies, so corporate domains must meet Avaya Aura Contact Center requirements.

 

Cause

TechNet Wiki article at https://social.technet.microsoft.com/wiki/contents/articles/1906.small-business-server-2011-standard-build-document-i-overview-of-sbs-2011.aspx#PLANNING_OF_THE_SETUP . It essentially says that since they were on Small Business Server, they cannot support trust domains.

PLANNING OF THE SETUP
Partitioning a server is a religious argument.  Whatever configuration you decide, ensure that you configure at least 120 gigs for the main C: partition.  This to ensure you have plenty of room for the SXS folder  When you install SBS 2011 it installs the entire server image on the C: drive and then once the server is completed you have the option to go back and use the console wizards to move Exchange data, SharePoint data and WSUS data.  Remember that like all SBS’s before it, while you can have additional domain controllers, you cannot have two SBS’s in the same network with the exception of the 21 days during the migration period.  SBS 2011 standard supports a maximum of 75 users or devices, must be the PDC, hold the FSMO roles, and cannot support trust domains.   

Solution

Customer Domain does not support two-way trust.

Additional Relevant Phrases

"CCT connection error". A couple minutes later agents where able to reconnect and started getting calls, but historical reports are still not working.

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