ACR 12.0: Questions around PostgreSQL database size and maintenance


Doc ID    SOLN326438
Version:    1.0
Status:    Published
Published date:    14 Jun 2018
Author:   
Imaobong Ekwere
 

Details

WFO 12.0
Questions around PostgreSQL database size and maintenance. Current CSR PostgreSQL is 90 GB and we continuously bump against disk space issues.Need to know best practices and expected sizing.

Problem Clarification

Needed to have some best practice document/information on how best to size the drive to accommodate the volume of calls stored on the PostgreSQL as it was currently on 90GB and there has been many issues with the disk drive running out.

Cause

The 'Call details' stored on the PostgreSQL DB has retentionship period for 6years as per business needs to keep their Archive calls for 6years.

So “Retain Call details for (months)” is the information stored in the Postgres database for both archived and call buffer calls. So since storing calls for 6years on the Archived, there is need to also have the Call details retained for 6years.

In that case, the best option will be for the business to expand the disk space to accommodate the call details retained for 6years so calls on the Archived can be played back otherwise the ACR will not know about those calls and will hinder playback.

Solution

From the ACR PIA guide contains the Performance and Sizing Guide information for the ACR servers. Kindly review them especially from pages 56 - 59….103 – 106 (This can also be reviewed further/wider).

Please note this sizing is on the Minimum as it depends on the length of calls/hours/average duration/how long to retain. It also depends if there is any custom data that is collected by the business in addition to the regular Call details/files collected daily. It is advisable to ensure appropriate and active Vacuum/purge process in place.

Attachment File

acradmin_en.pdf
0Bytes • < 1 minute @ 56k, < 1 minute @ broadband



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