Policy Manager 3.0 UI not accessible - Error: An unexpected error has occurred. Please refer to logs for more information


Doc ID    SOLN326492
Version:    3.0
Status:    Published
Published date:    05 May 2020
Created Date:    15 Jun 2018
Author:   
Rosalia Trujillo
 

Details

Policy Manager 3.0

Problem Clarification

Unable to access UI Error: An unexpected error has occurred.  Please refer to logs for more information. Following error seen in the /opt/avaya/SAL/policymgr/logs/polmgr-operational.log:

<11>Jun 15 20:30:56 ADSSALPol polmgr[3167]: +02:00 2018 447 1 com.avaya.sal.policymgr | 1 com.avaya.polmgr.common.logging O_PM-SE00186E O_PM-SE00186E {,en_US,SAST}@{SAL_PM[10.X.XX.XXX,]} | SAL_PM[10.X.XX.XXX,] | OPERATIONAL -  | DATABASE CONNECTION ERROR - - - [-:-] 500 {A read-only user or a user in a read-only database is not permitted to disable read-only mode on a connection.A read-only user or a user in a read-only database is not permitted to disable read-only mode on a connection.}

 

SAL Policy Manager login webpage does not appear; WEB GUI Error message: "An unexpected error has occurred.  Please refer to logs for more information."

Cause

File db.lck  in /opt/avaya/SAL/policymgr/policyMgr is owned by root:root instead of policyuser: policygroup

Solution

Move db.lck file to db.lck.bk "(mv db.lck db.lck.bk")  then restart the following  3 services:

polMgrServer, polMgrUI & sshproxy

 db.lck file will be recreated with correct policyuser ownership. Proceed to delete backup file db.lck.bk

Additional Relevant Phrases

Policy Server has no web access

Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy