One-x Communicator: Audio volume gone down in between call and both user unable to hear each other


Doc ID    SOLN327293
Version:    1.0
Status:    Published
Published date:    11 Jul 2018
Author:   
Ghanshyam Chauhan
 

Details

 One-x Communicator - 6.2.12.12

Problem Clarification

 Avaya one-X® Communicator is running on a Windows® based PC, When user answer call and start talking with customer suddenly voice gone lower. After that user have to disconnect call and recall customer.

Cause

Asked user to check audio statistics when issue happen next time. Also, asked user when issue happen next time HOLD/UNHOLD option. But, Issue doesn't restore. During one-x logs investiagtion I found SRTP issue.

 
We see below in logs for bad calls, SRTP active inbetween call and thats reason users observing this issue.
I would be checking what is happening with RTP packets when we see the following in sniffer.
 
[06/07/2018 13:19:38:245] DBG:      MEDIA: [3e2c] SrtpCryptoContext::CryptoContext::Update: SSRC change from 0x280863AD to 0x5003EB72 
[06/07/2018 13:19:38:245] DBG:      MEDIA: [3e2c] SrtpCryptoContext::CryptoContext::Update: SSRC:0x5003EB72 Initialize ROC: 0, sequence: 0, index: 0 
[06/07/2018 13:19:43:562] ERR:      AUDIO: [3e2c] WebRTCAudioAdapter::CallbackOnError(): channel: 10020, error: -1

Solution

 Customer waiting for internal approval to enable sniffer. Inbetween we had got information from user that they are connecting there headset at docking station. We asked them to move USB of the headset to direct laptop port and issue doesn't occur again.


Avaya -- Proprietary. Use pursuant to the terms of your signed agreement or Avaya policy