SMGR 7.1.3: Migrating from SMGR 6.2 to 7.1.3 is Failing using the Data Migration Tool


Doc ID    SOLN328628
Version:    5.0
Status:    Published
Published date:    17 Nov 2018
Created Date:    17 Aug 2018
Author:   
Mutaz Ammous
 

Details

Cannot login to system manager 7.1 after data migration from Rel.6.2

Data migration tool is failing

Problem Clarification

When trying to migrate the SMGR to 7.1.3 using the following steps:

1. SMGR-7.1.0.0.1125193-e65-50.ova on Client VMware ESXi Host 6.5.

2. Copying the datamigration-146.bin, the Release 7.1.3 bin file (System_Manager_7.1.3.0_r713007763.bin), and the 6.2 System Manager backup file to the /swlibrary location on System Manager and use below commands for migration.
a) upgradeSMGR /swlibrary/datamigration-146.bin -m -v
b) /swlibrary/1_2018_Jul_30_02_33_15_538.zip
c) /swlibrary/System_Manager_7.1.3.0_r713007763.bin

After following the above correct steps, the migration fails. Checking the /var/log/Avaya/datamigration/data_migration.log the following error was found:

****************************
TM Initialization failed. Unable to contact TM Service.
****************************
****************************
TM Initialization failed. Unable to contact TM Service.
****************************
Return Code: 1 (TM Initialization failed. Unable to contact TM Service.)
Return Code: 1 (TM Initialization failed. Unable to contact TM Service.)
Tue Aug 7 13:05:45 AST 2018 SMGR :: Execution failure: Trust Initializer- exit status 1
Tue Aug 7 13:05:45 AST 2018 SMGR :: Execution failure: Trust Initializer- exit status 1
Tue Aug 7 13:05:45 AST 2018 MgmtID :: FAILED at 14: Execution of script /opt/Avaya/vsp/MgmtID/MgmtID_TM.sh - exit status 20
sh: /tmp/temp_remove_bak.sh: No such file or directory
mv: cannot stat ‘/opt/Avaya/vsp/MaintainSMGR/.SMGR_Maintenance.lock’: No such file or directory
Tue Aug 7 13:06:05 AST 2018 AURA :: TM Upgrade failed
Tue Aug 7 13:06:05 AST 2018 ## Upgrade failed. ##
Tue Aug 7 13:06:05 AST 2018 #### Data migration failed. ####

Cause

The issue was related to the old SMGR backup file.

Went back onto the old 6.2 system currently in production and ran validateSMGR script. This showed one particular issue as follows:

Sane amount of stale jobs? 716063 [ WARNING ]

The above issue will cause OutOfMemory and performance issues on SMGR if not resolved.

Solution

1- Delete the stale entries from the production SMGR servers Database (use SOLN300698 for more details on that).
2- Restart jboss on production and the old SMGR was much quicker to come back than normal (indication of successful step above);
3- Perform a new backup of the old production SMGR.
4- Restore VM snapshot of new 7.1 SMGR back to working condition (Prior to data migration attempt)
5- Follow the SMGR migration steps mentioned above.

After doing the all the above with the new clean backup file, the migration was successfully completed to SMGR 7.1.3.

kindly check section Upgrading to System Manager Release 7.1.3 from CLI from the following document https://downloads.avaya.com/css/P8/documents/101038550 for more details on how to do the upgrade.

Additional Relevant Phrases

Upgrade fails while upgrading to 7.1.3 migration failure from 6.3 to 7.2 upgrade fail during data migration

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