[Stationlink] After forced shutdown of Windows, Stationlink became to fail to start up. At that time user cannot see any error message.


Doc ID    SOLN329018
Version:    1.0
Status:    Published
Published date:    30 Aug 2018
Author:   
kyoshitake
 

Details

One day user's windows PC was unexpectedly shutdown. After user booted PC again, user noticed he cannot start up stationlink.

No error message popped up but user monitored Taskmanager and he was able to see stationlink process disappear about 10 secs later every time.
Additionally, there were no useful record in stationlink log, but we were able to confirm error in the event log.

障害が発生しているアプリケーション名: StationLink.exe、バージョン: 4.4.1.0、タイム スタンプ: 0x59e4688d
障害が発生しているモジュール名: KERNELBASE.dll、バージョン: 10.0.16299.15、タイム スタンプ: 0x2cd1ce3d
例外コード: 0xe0434352
障害オフセット: 0x001008b2
障害が発生しているプロセス ID: 0x3b18
障害が発生しているアプリケーションの開始時刻: 0x01d43f418f73acab
障害が発生しているアプリケーション パス: C:\Program Files (x86)\Avaya\StationLink\StationLink.exe
障害が発生しているモジュール パス: C:\windows\System32\KERNELBASE.dll
レポート ID: 9b4d3807-7dda-43a0-b121-c677f27c99ee
障害が発生しているパッケージの完全な名前:
障害が発生しているパッケージに関連するアプリケーション ID:

Problem Clarification

User re-installed TSAPI client and Stationlink application, but it was not able to solve issue. And, TSAPI test tool is working fine.

According to event log we guess something file of .NET Frameworks could be corrupted.
 

Cause

user.config file corrupted.

Solution

Move or Rename user.config file.

C:\Users\(user name)\AppData\Local\Avaya_Inc\StationLink.exe_Url_(Hash value)\(version)\user.config

We cannot support windows and other microsoft products but if you faced same situation I recommend to try this solution before uninstall a whole of OS.
 


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