CM, OneX softphone unable to use answer button after PC idle for 10 minutes or more.


Doc ID    SOLN329030
Version:    2.0
Status:    Published
Published date:    18 Sep 2018
Created Date:    30 Aug 2018
Author:   
jschug
 

Details

Users Onex client freezes when left Idle for too long. Appears to cause delay in call pickup when ringing.
Have agent remain idle with the PC for 10 minutes and then make a call - the Onex client is hung and agent is unable to use answer button.

Started as soon as installed OS: Windows 10 version 1703
Make/Model: HP 840 G3
Avaya one-X Version: 2.5.58020.802

Problem Clarification

After Windows PC update pushed, One-X softphone answer button stops working after PC has been idle for 10 minutes or more.

Cause

Windows PC update; exact update was not known, however once the latest updates to the PC were removed the issue resolved

Solution

Collected logs from the One-X station:

Good Call:

2018-08-22 14:53:48,244 INFO 8932 Avaya.OneXAgent.WorkService.WorkServiceImpl PhoneService_CallUpdated:call=Id=9,Conf-Id=-1,State=Alerting,InnerState=INIT,RemoteParty=[MyAngel,1212720xxxx]Outgoing=False
2018-08-22 14:53:57,506 DEBUG 10996 OneXAgentUI.MainWindow GUI Method STARTED: AnswerCallHandler
2018-08-22 14:53:57,713 DEBUG 13784 Avaya.OneXAgent.CMService.Commands.Dispatcher Dispatcher: Received Event - SessionUpdatedEvent
2018-08-22 14:53:57,713 DEBUG 13784 Avaya.OneXAgent.CMService.PhoneService.Call Call updated : Id=9,Conf-Id=-1,State=Alerting,InnerState=CONNECTED,RemoteParty=[MyAngel,1212720xxxx]Outgoing=False
2018-08-22 14:53:57,714 DEBUG 13784 Avaya.OneXAgent.CMService.Commands.Dispatcher Dispatcher: Received Event - EstablishedEvent
2018-08-22 14:53:57,716 DEBUG 13784 Avaya.OneXAgent.CMService.Commands.Dispatcher Dispatcher: Received Event - AcceptSessionResponse
2018-08-22 14:53:57,967 DEBUG 10996 Avaya.OneXAgent.CMService.PhoneService.Utils End Executing method Answer
2018-08-22 14:53:57,974 DEBUG 10996 OneXAgentUI.MainWindow GUI Method ENDED: AnswerCallHandler

Bad Call

2018-08-21 13:55:05,761 DEBUG 14308 OneXAgentUI.MainWindow GUI Method STARTED: AnswerCallHandler
2018-08-21 13:55:05,762 INFO 14308 Avaya.OneXAgent.WorkService.WorkServiceImpl AnswerVoiceInteraction:vi=VoiceInteractionImpl[VI54:bfb35f3b-2dee-4fe9-aadb-6f8874290fac,cxt=219555cf-ea30-4dd1-9217-ec149cc3835a]
2018-08-21 13:55:05,762 DEBUG 14308 Avaya.OneXAgent.CMService.PhoneService.Utils Begin Executing method Answer(Call[Id=219555cf-ea30-4dd1-9217-ec149cc3835a,ConnId=19,State=Alerting])
2018-08-21 13:55:05,762 DEBUG 14308 Avaya.OneXAgent.CMService.Commands.AcceptSessionCommand Sending Request AcceptSessionRequest, timeout = 15000ms
2018-08-21 13:55:05,762 DEBUG 14308 Avaya.OneXAgent.CMService.Commands.Dispatcher Sending Request - AcceptSessionRequest
2018-08-21 13:55:05,773 DEBUG 5692 Avaya.OneXAgent.CMService.Commands.Dispatcher Dispatcher: Received Event - SessionEndedEvent
2018-08-21 13:55:05,773 DEBUG 5692 Avaya.OneXAgent.CMService.Commands.IncomingHandlerCommand IncomingCommandHandler: Received event - SessionEndedEvent
2018-08-21 13:55:05,773 DEBUG 5692 Avaya.OneXAgent.CMService.Commands.IncomingHandlerCommand Call ended : Id=19,Conf-Id=-1,State=Alerting,InnerState=INIT,RemoteParty=[!My Ramirez,1904632xxxx]Outgoing=False
2018-08-21 13:55:05,773 DEBUG 5692 Avaya.OneXAgent.CMService.PhoneService.PhoneServiceImpl NotifySessionReleased: ConnectionId = 19
2018-08-21 13:55:05,773 DEBUG 5692 Avaya.OneXAgent.CMService.PhoneService.Call Call StateChanged Call[Id=219555cf-ea30-4dd1-9217-ec149cc3835a,ConnectionId=19,OldState=Alerting,NewState=Disconnected]
 
To resolve: Removed latest Windows 10 PC updates.

 


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