IC 7.3: Services were down after server reboot


Doc ID    SOLN209981
Version:    6.0
Status:    Published
Published date:    30 Sep 2020
Created Date:    11 Sep 2012
Author:   
Pradeep Patil
 

Details

Interaction center Version: 7.3.x: Windows Environment

Problem Clarification

Under maintenance window, IC servers were rebooted. Secondary IC did not come up after server reboot. WACD and Event Collector were down.

Cause

IC Servers were not rebooted in order and caused the ORB service to not come up on the secondary server, also causing the Event collector and WACD to hang.

Solution

Recommended customer to follow reboot procedure of IC server.Follow these steps on each of IC server machine box as per requirement of the issue [ i.e IC Primary, Secondary, Email, Web Server].
Note:This procedure is for IC setup on windows.

To stop the IC Services on Windows :
 
1. Bring up the Windows Services application. Stop all of the following services (some may not exist on every IC server):
  • Avaya IC Customer Infrastructure Readiness Survey (CIRS) Service 7.x
  • Avaya IC Email Template Management Service 7.x
  • Avaya Indirect Channel Manager (ICM) Service 7.x
  • Avaya IC Object Request Broker (ORB) Service 7.x
  • Avaya IC Test Service 7.x
  • Avaya IC Web Management Service 7.x
  • Avaya IC Web License Manager (WebLM) Service 7.x
  • Avaya Voice Media Manager
2. Stop the IC servers
 
3. Stop IC servers on any of the supported platforms using either IC Manager or the Avaya IC Administration Utility
 
From IC Manager :
 
User cannot stop the ORB server using IC Manager. To stop all of the other IC servers in the proper order using IC Manager:
  1. Start IC Manager, if it is not already running
  2. Select the Server tab
  3. Select the Server>Shutdown menu option
  4. Select the IP address or the name of the machine to stop servers
  5. Click OK
Avaya IC Administration Utility. To stop all IC servers using the Avaya IC Admin Utility:
  1. In a command window, navigate to the \IC7.x\bin directory
  2. If servers are installed on different machines, type icadmin tva <username> <password>
  3. If servers are installed on the same machine, type icadmin tv <username> <password>
  4. Click 'Enter'
Ensure all IC servers has stopped Windows:
  1. Go to Task Manager dialog
  2. Click the Process tab to view a list of the processes on the machine
  3. Make sure the IC servers are not running
==================
Restart the IC servers by running both of these tools in the following order:
  • Avaya IC Administration Utility
  • IC Manager
Note: The system reboot is only required for installations on Windows. Solaris and Advanced IBM Unix (AIX) systems need not be rebooted.
Avaya IC Administration Utility
 
To restart the ORB server using the Avaya IC Administration Utility on the server machine:
 
1. In a command window, navigate to the following directory:
Windows: \IC7.x\bin
 
2. Type the following command:
Windows: icadmin so
From IC Manager, restart the IC servers individually and in the proper order.
 
After restarting IC servers individually, restart IC services.Windows to start the IC Services:
  1. Bring up the Windows Services application
  2. Start any of the following services that are not already started (some may not exist on every server)
  • Avaya IC CIRS Service 7.x
  • Avaya IC Email Template Management Service 7.x
  • Avaya ICM Service 7.x
  • Avaya IC ORB Service 7.x
  • Avaya IC Test Service 7.x
  • Avaya IC Web Management Service 7.x
  • Avaya IC WebLM Service 7.x
  • Avaya Voice Media Manager

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