CM: Unable to dial 1800 number from trunk group 10 fails with SIP 603 Decline


Doc ID    SOLN247128
Version:    4.0
Status:    Published
Published date:    16 Apr 2018
Created Date:    20 Mar 2014
Author:   
pontones
 

Details

CM: Call via internal VDN Extension to External Number fails with SIP 603 Decline

CM: R016x.02.0.823.0
Patch: 20954 for 02.0.823.0
 

Problem Clarification

Customer is dialing an internal VDN Extension (69500) which terminates to an external number via SIP trunks (Session Manager):

list extension-type 69500

EXTENSION TYPE

COR/ Cv1/
Ext Type/Name COS TN Cv2
--- --------- --- -- ----
69500 VDN-extension 4 1
Test 1

display vdn 69500 Page 1 of 3
VECTOR DIRECTORY NUMBER

Extension: 69500
Name*: Test
Destination: Vector Number 253
Attendant Vectoring? n
Meet-me Conferencing? n
Allow VDN Override? y
COR: 4
TN*: 1
Measured: external

Service Objective (sec): 20
VDN of Origin Annc. Extension*:
1st Skill*:
2nd Skill*:
3rd Skill*:

 

* Follows VDN Override Rules


display vector 253 Page 1 of 6
CALL VECTOR

Number: 253 Name: local spoc rte
Multimedia? n Attendant Vectoring? n Meet-me Conf? n Lock? n
Basic? y EAS? y G3V4 Enhanced? y ANI/II-Digits? y ASAI Routing? y
Prompting? y LAI? y G3V4 Adv Route? y CINFO? y BSR? y Holidays? y
Variables? y 3.0 Enhanced? y
01 wait-time 0 secs hearing ringback
02 route-to number 918881234567 with cov n if unconditionally
03 stop


If the customer dials the VDN 69500 the call fails with:

time data
13:30:47 SIP>INVITE sip:18881234567@xyz.com SIP/2.0
13:30:47 Call-ID: 80dafdd4eab4e3199d952e5919f00
13:30:47 dial 918881234567 route:ARS
13:30:47 route-pattern 301 preference 1 location 3 cid 0x27b2
13:30:47 seize trunk-group 60 member 213 cid 0x27b2
13:30:47 Setup digits 18881234567
13:30:47 Calling Number & Name *8609991111 xxx, yyy
13:30:47 SIP<SIP/2.0 100 Trying
13:30:47 Call-ID: 80dafdd4eab4e3199d952e5919f00
13:30:47 Proceed trunk-group 60 member 213 cid 0x27b2
13:30:48 SIP<SIP/2.0 603 Decline <-- SIP/2.0 603 Decline
13:30:48 Call-ID: 80dafdd4eab4e3199d952e5919f00
13:30:48 SIP>ACK sip:18881234567@xyz.com SIP/2.0
13:30:48 Call-ID: 80dafdd4eab4e3199d952e5919f00
13:30:48 253 3 LEAVING VECTOR PROCESSING cid 10162
13:30:48 idle cid 0x27b2

If the customer dials the full number 918881234567 directly instead of dealing the VDN the call completes successfully:

11:40:31 SIP>INVITE sip: 18881234567@xyz.com SIP/2.0
11:40:31 Call-ID: 801ef697a4b5e31ccb952e5919f00
11:40:31 dial 918881234567 route:ARS
11:40:31 route-pattern 301 preference 1 location 3 cid 0x1927
11:40:31 seize trunk-group 60 member 78 cid 0x1927
11:40:31 Setup digits 18881234567
11:40:31 Calling Number & Name *8609991111 xxx, yyy
11:40:31 SIP<SIP/2.0 100 Trying
11:40:31 Call-ID: 801ef697a4b5e31ccb952e5919f00
11:40:31 Proceed trunk-group 60 member 78 cid 0x1927
11:40:33 SIP<SIP/2.0 183 Session Progress
 

Cause

VDN 69500 was missing an entry in the: public-unknown-numbering table

 

Solution

Add the following entry:

list public-unknown-numbering Page 1
NUMBERING - PUBLIC/UNKNOWN FORMAT
Total
Ext Ext Trk CPN CPN
Len Code Grp(s) Prefix Len

5 69 8605556677 10

From the Traces we can see,

 

CM sends an Invite to SIP provider to dial that number

 

14:57:35 SIP>INVITE sip:18883319194@milbank.com SIP/2.0

 

SIP Provider sends 100à Trying, But does not send 180 à Ringing

 

14:57:35 SIP<SIP/2.0 100 Trying  

 

But the SIP provider is sending decline to CM.

 

SIP<SIP/2.0 603 Decline

 

This means that the SIP provider has declined the call. 

 

Can you please contact the SIP provider and ask them to change the programming on the SIP line to accept the call. As from the traces we can clearly see the SIP provider is declining the call.

 

 

 


 

Additional Relevant Phrases

Particular extension is not able to get the incoming calls, called persons getting fast busy.

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