AACC SP 12 : Unable to login user to CCMS - VoiceTerminalAcquisitionFailed


Doc ID    SOLN247515
Version:    3.0
Status:    Published
Published date:    10 Feb 2016
Created Date:    27 Mar 2014
Author:   
Swapnil Gurav
 

Details

 

AACC version SP 12 MC setup

Problem Clarification

 

This was a lab system with Sp12 line up. Earlier we were able to login AAAD successfully, where as later user were not able to log into AAAD giving below error:

                                   Unable to login user XXXX to CCMS VoiceTerminalAcquisitionFailed
 

2015-07-08 09:29:19.404       CCTSERVER             79-24096 0              Minor      None       CallOut    User 3253               User.Login - Caught CMF AgentLoginException: ErrorCode=41 ("The agent login failed due to an internal system error."), FailedContactType="", Message=login():Error - Passive Terminal Login Failure for Agent [3253](Known ErrorCode):: SP Application sent back error [25] :: with exMessage[Login failed because Agent Phoneset is unavailable. Please make sure the Phoneset is logged in.]

2015-07-08 09:29:19.404       CCTSERVER             79-24096 0              Debug      None       CallOut    User 3253               User.Login - Throwing CCT OperationFailureException: Error=AgentLoginFailed, ErrorInfo="", Message=The agent login failed due to an internal system error.

2015-07-08 09:29:19.405       CCTSERVER             79-24096 0              Minor      None       CallIn       Agent 3253/Session 147 (MAIN\J0294093)          Login - OperationFailureFault: Error=VoiceTerminalAcquisitionFailed, Info="", Message="The agent login failed because the phoneset could not be acquired.  Please make sure the phoneset is logged in (registered) and there are no calls active, then try the login again."

 

2015-07-08 09:30:15.004       CCTSERVER             115-16500               0              Minor      None       CallOut    AgentAddress sip:3240@ukmkt.ad.ge.corp.local          AgentAddress.SetAcquireStatus - Caught CMF ServiceProviderPlatformException: ErrorCode=7 ("The destination party is currently out of service."), SPError=<null>, SPMessage=ID:00000002 If you are using "My Computer" mode you can ignore this message. If using "Desktop Phone" mode with a physical phone set you must make sure your phone is registered before you can log into AACC on AAAD

015-07-08 09:30:15.004         CCTSERVER             115-16500               0              Debug      None       CallOut    AgentAddress sip:3240@ukmkt.ad.ge.corp.local          AgentAddress.SetAcquireStatus - Throwing CCT OperationFailureException: Error=DestinationOutOfService, SPError=<null>, Message=ID:00000002 If you are using "My Computer" mode you can ignore this message. If using "Desktop Phone" mode with a physical phone set you must make sure your phone is registered before you can log into AACC on AAAD

 

Cause

From AACC logs, we can see agent phoneset couldn't be acquired by CCMS when login to AAAD. But agent has logged into his CM One-x station. That means there is some issue in the acquisition of CM phone by CCMS through AES.

 Please check the AACC-AES link and CTI link when the issue occurs. Seems CTI link was down and not able to communicate with CM.

Verified AACC-AES configuration & configuration was fine. However we have observed that TSAPI & DMCC services on AES were running in RISTRICTED MODE.

In dmcc-error.log at /opt/mvap/logs, we have seen below:

2014-03-26 13.54.57,701 :T-29: com.avaya.licensesvc.LicenseServiceImpl setLicenseMode
SEVERE: The AES License Service grace period has expired - suspending DMCC licensing.
Before continuing, you must fix the following problem: No license file for the Application_Enablement product was found. Please install an appropriate license file for the AE Server.
2014-03-26 14.03.57,696 :T-29: com.avaya.licensesvc.LicenseServiceImpl setLicenseMode

Solution

Created new AES license & after appling new license, AAAD agent were able to login successfuly.


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