96xx IP Telephones: 96x1 and 96x0 Weather and World clock applications not working


Doc ID    SOLN262524
Version:    10.0
Status:    Published
Published date:    02 Mar 2020
Created Date:    21 Jan 2015
Author:   
Jose Ivan De Souza Proenca
 

Details

96x0 and 96x1 type phones running on current latest GA software

Problem Clarification

World Clock and/or Weather Application not working, the weather server responds with a “‘Command’ requires a valid API key” error.

If a sniffer/ethereal trace be collected and analyzed, it can be found in it that the phone sends a get command to the server. In the response message to that get command, the weather  server responds with a “‘Command’ requires a valid API key” error.

At another cutomer using 9641G with SP6.4, they were getting the error “Could not access internet service”.

Cause

As a FYI, we actually document in the 96x1 documentation that this service is not guaranteed. Refer to the attachment of this KB.

It is not a phone issue.  It is a problem with the API key and can be reproduced even from a PC if trying to use this API key.

Solution

Avaya R&D contacted the WeatherChannel team and the service was restored by the WeatherChannel.com team. The issue was re-tested and confirmed as service restored at a client.

As a FYI, we actually document in the 96x1 documentation that this service is not guaranteed. Refer to the attachment of this KB.

Should you/your client be currently facing such issue, you may

1) reboot phone and re-test

2) report into Avaya Services by providing with the following:

a) picture of error message seen on the phone's display

b) capture the issue in a sniffer/ethereal trace

c) collect phone's settings.txt file and DHCP option used onsite

No changes were made on Avaya Side. World app made the changes and as the 96x1 documentation that this service is not guaranteed please follow the below KB soln to remove it from phone display if it no longer works.

Communication Manager : How to disable the web application Icons on 9670G Phones

https://support.avaya.com/kb/index?page=content&id=SOLN224865

SOLN224865

There is an option to disable the World Clock Application , Weather Application &
Calculator

If you need more contacts to be favorite you can change the below settings on the
46xx settings file.

## WORLDCLOCKAPP specifies the application to display World Clock information.
## "" : World Clock application is disabled
## "default" : World Clock application is enabled (default)
SET WORLDCLOCKAPP ""
##
## WEATHERAPP specifies the application to display the weather information.
## Value Operation
## "" (null) Weather application is disabled
## "default" Weather application is enabled (default)
## This parameter is supported by:
## 9621 and 9641 H.323 R6.0 and later
## 9670 H.323 R2.0 and later
SET WEATHERAPP ""
##
## CALCSTAT specifies whether the Calculator application should be displayed.
## Valid Values
## 0 Don't display Calculator
## 1 Display Calculator
SET CALCSTAT 0

 

 

Attachment File

Additional Relevant Phrases

The Weather and World Clock applications on the 9670G, 9641G, and 9621G IP deskphones are reliant upon a data feed from weather.com that has been recently terminated and was removed on November 4, 2011. Thus this functionality will no longer work: This has been resolved in Release 3.1 Service Pack 5, available on support.avaya.com: https://support.avaya.com/downloads/download - details.action?contentId=C20128241247136410_4&productId=P0553 And also has been resolved in Release 6.2 Service Pack 2, available on support.av aya.com: https://support.avaya.com/downloads/download - details.action?contentId=C20127302050128220_1&productId=P0553

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