Equinox Meetings Online: Poor Video Quality Experienced By WebRTC Users On Firefox Browser


Doc ID    SOLN340808
Version:    3.0
Status:    Published
Published date:    27 Jun 2019
Created Date:    21 Jun 2019
Author:   
Vineet Kotagiri
 

Details

 

Avaya Equinox Meetings Online running software version proir 9.1.8 

Problem Clarification

 

One specific customer with AEMO subscription reported an issue stating that the call quality on WebRTC client when using Firefox browser is poor.

When using Chrome browser from that same PC, the call quality is good.

So they want to to know the reason for the difference in behavior.

Cause

 

The current implementation of WebRTC by default tries to adjust and re-negotiate the call bandwidth and resolution when it runs into network congestion problems that affect the presentation/collaboration.

The presentation channel typically requires about 400K of bandwidth and anytime the available bandwidth for presentation falls below that, it would trigger this behavior and lower the call bandwidth and hence resolution.

Chrome browser handles network congestion better than Firefox and hence the issue is more readily apparent in Firefox where the call quality can degrade quickly when connecting via congested networks.

Solution

 

In the interim, it is recommended for the customer to continue using Chrome browser for their WebRTC connections.

The upcoming release of AEMO that is planned around the end of July 2019 will include some improvements in the WebRTC implementation.

 

 

 

Additional Relevant Phrases

WebRTC poor video quality on Firefox browser; WebRTC video quality difference between Chrome and Firefox

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