Workplace client unable to update the software.


Doc ID    SOLN370400
Version:    1.0
Status:    Published
Published date:    17 May 2022
Author:   
Prabhakar Bhogate
 

Details

User when trying to update Software version on Avaya Workplace -> Software Update -> 'Install update' button. They are getting Update Error! "An error occurred in retrieving update information; are you connected to internet? Please try again later."
one observation while testing with user. Even though users are facing issue manually updating the workplace version. On the next day when they saw the workplace version they found it to be automatically updated to latest version.
This behaviour was observed with multiple users. So primarily the issue only happens during manual update attempts.

 

Problem Clarification


 
 

 

Cause

Possible causes Identified from the Workplace log analysis.
  1. Version is set incorrectly on AADS. It should be in four digits format. Otherwise, there would be issues triggered by .NET Framework that expects only 4 digits for version. It is not a critical failure and is not preventing client from proceeding with upgrade. It could be seen in logs.
 
2022-05-05 17:49:23.262 E [14372/UI] [Updater] Updater: Exception during download sparkle feed file System.ArgumentException: Version string portion was too short or too long.
at System.Version.VersionResult.SetFailure(ParseFailureKind failure, String argument)
 
Version set in sparkle feed file: sparkle:version="3.26.0.64.42"
Expected format is: sparkle:version="3.26.0.64"
 
  1. There is inconsistency in configuration related to webdeployment URLs. Client is configured to download appcast file (sparkle feed) from: https://vservices-conf.mckinsey.com:8442/acs/resources/webdeployment. Please note that the port is 8442.
 
However in the response, URL to download installer has 443 port.
 
<enclosure url=https://vservices-conf.mckinsey.com:443/acs/resources/webdeployment/downloads/Avaya Workplace Setup 3.26.0.64.42.msi sparkle:version="3.26.0.64.42" sparkle:os="windows" length="78528512" type="application/octet-stream" sparkle:dsaSignature="92855da23e5b52dd8ae726f60400ae76"/>
 
It indicates that procedure described in https://download.avaya.com/css/public/documents/101079249 page 353 (Running a patch to allow Avaya Workplace Client for Windows to connect to the Web Deployment service) was not executed correctly. Client is provisioned still with an old port.
 
  1. From the logs there are issues with AADS connectivity. They are not related to webdeployment and this case with upgrade. But still needs to be troubleshooted. From the logs each resources discovery fails with connection timeout.
 
2022-05-05 15:04:07.402 E [ 7488] [CSDK] clientsdk::CPocoHTTPSession::CHTTPRequestTask::ExecuteTask[012F8878](): Error from https://vservices-conf.mckinsey.com:443/acs/resources: eCONNECTION_TIMEOUT: [code: 10060, exception: class Poco::TimeoutException] Timeout:
 

Solution


Changing port number on AADS 'Web Deployment' Tab from 443 to 8442 fixed the issue.
We will need to make changes in below highlighted string on AADS web page as suggested by T4 and retest the scenario.




 

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